Jump to content
Sign in to follow this  
AdamS

Periodic 'Error response code 504'

Recommended Posts

One of my client's gets periodic 'Error response code 504' when attempting to search.

 

Restarting the Connect instance or the server generally fixes it but it keeps occurring at semi regular intervals.

 

running Connect 2.0.

 

Any idea's/thoughts?

Share this post


Link to post
Share on other sites

Hi Adam,

 

504 error code indicates a connection timeout which happens when response is not ready in 3 minutes. Based on the description this might be caused by a long running complex search queries - but we would have to look at the logs in order to be sure.

Share this post


Link to post
Share on other sites

I don't think it's due to complex queries in this instance as my client is only running single word or short phrase queries. Next time it happens I'll send the log files through to support and see if that sheds some light on it.

Share this post


Link to post
Share on other sites
On 11/21/2018 at 4:53 PM, Vince said:

Did you by any chance ever find the source of your Error 504 AdamS? We are experiencing the same issues with searching by keyword list. Thanks

Vince, maybe your keyword search is too complex to be evaluated in 3 minutes timeout. The solution might be to split it into smaller chunks or reduce the complexity (by eliminating excessive use of wildcards, for instance). There might also be a way out by bumping the timeout parameter to a higher value.

Share this post


Link to post
Share on other sites

Has anyone gotten a resolution to the 504 error? We are also experiencing the error and don't have the option of breaking up the search parameters. Its  not really a complex search, just the number of parameters/terms is large.

Share this post


Link to post
Share on other sites

Hi again,

What you can try to do is to extend the default timeout of 3 minutes to a larger value by means of trial and error (4, 5, 6 mins...). To do this one has to modify "C:\Users\ACCOUNT_RUNNING_CONNECT\AppData\Roaming\Intella Connect\prefs\user.prefs" file by adding the following line: 

ReverseProxyTimeout=XXX

where XXX is the new value in milliseconds (defaults to 180000). Intella Connect restart would be required.

In general it should be ok to do this, but keep in mind that such timeouts are added for a reason and setting this value too large can result in performance degradation if not used wisely.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...