Jump to content

Removing tags in Connect not working


markjrouse
 Share

Recommended Posts

Hi,

 

Experiencing an unsual issue with Intella Connect.  In Intella Pro, I've created a 'Privilege' tag and have selected relevant docs as privilege. Now when I share the case, and I log into Intella Connect as the case administrator, and select all my privilege tagged items from the Tags facet, I go into one of those documents in the previewer, and I have noticed that under the "Add or Remove Tag" button, for my selected document, I can't untick the Privilege tag checkbox - the mouse cursor changews to a red stop circle.

 

Any thoughts on why this is the case?

 

My role "Case Admin" has all avaiable permissions assigned under the authorisations section of the server.

Link to comment
Share on other sites

Ok, now I understand. In Intella Connect 1.7.3 only administrators are allowed to remove tags and taggings created by other users. In the upcoming release of Intella Connect, there will be a separate permission named "Can delete tags and taggings created by others". Users having this permission will be able to do what you need, even if they are not admins.

 

However, regardless of permissions one should always be able to delete his own taggings or even entire tag (if no other users have used it).

Link to comment
Share on other sites

I'm using Connect 1.7.4 and there is already a "Can delete tags and tags from other reviewers" as an available permission, but it doesn't seem to do much.  How do I make my mrouse user an administrator? If I login as admin it takes me to the server management console, not the review platform!!

Link to comment
Share on other sites

If you have set mrouse as an 'admin' for that case then it sounds like it may be a glitch. You said you are using 1.7.4 so that sounds like a beta version maybe as the current version is 1.7.3. Have you tried opening the case with Intella directly and editing the tags there?

Link to comment
Share on other sites

Hi AdamS,

 

Can't open the case directly with Intella Pro as the case is still being shared.

 

Okay, but if you unshare the case, remove the tags, then reshare should only be limited downtime for your shared case.....just a work around fix until the issue is solved I was thinking.

Link to comment
Share on other sites

Ok, so I tested this today on fresh case and everything looks OK. I'll describe the steps below. Mark, can you try to reproduce them on some test case?

 

  1. I was using two reviewers: 'lukasz' and 'primoz'
  2. I defined following Roles (Permissions in parenthesis):
    1. Reviewer ("Can access a case and participate in the review", "Can export items", "Can print item report")
    2. Tags admin ("Can delete tags and taggings from other reviewers")
  3. Initially I added both users to "Reviewer" role for my test case.
  4. I opened two browsers and signed in to a case with both reviewers.
  5. Using 'lukasz' I created a tag "new-tag-by-lukasz" and applied it to 2044 items - all good.
  6. Using 'primoz' I queried for the same items and also applied 2044 taggings - all good.

This is considered a starting point. Both users can access a case and create tags and taggings. Lukasz created the tag, so he is considered a creator of the tag. At this point Lukasz cannot delete taggings made by Primoz and vice versa. Lukasz can't delete the whole tag "new-tag-by-lukasz" as well, because it was used by Primoz to make some taggings. So at that point reviewers can only delete their own taggings and after Primoz will do so, Lukasz will be able to delete the whole tag.

 

To tackle such issues, we have developed the "Can delete tags and taggings from other reviewers" permission which was added to "Tags admin" role. So we will make use of it now.

  1. Coming back to "Authorizations" window for my test case, I added "Primoz" to role "Tags admin".
  2. Being logged in as Primoz, I first removed all my taggings for "new-tag-by-lukasz" from mentioned 2044 items. To do that, I simply selected those items and clicked used "Remove tags" feature.
  3. Then, I expanded "Tags Facet" and right clicked on taggings created by Lukasz. The "Delete" action is now enabled, so I deleted all the taggings created by Lukasz (see screenshot)
  4. Then, I right clicked on the "new-tag-by-lukasz" and deleted it as well.

That removed all the taggings created by both users and also the "new-tag-by-lukasz' tag. Frankly, removing taggings first was just a way of making sure this all works. If Primoz is granted with "Can delete tags and taggings from other reviewers" permission then he can right click on the tag in the "Tags Facet" and delete the tag along with all taggings created by all the users instantly.

 

I hope that this will help you out with reproducing the flow. Please let us know if everything is understandable now and works as expected.

deleting-tags-and-taggings.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...